WordPress 4.6 Compatibility

With WordPress v4.6 there is a conflict which causes DS-CLI (and WP-CLI) compatibility issues. In order to resolve this, we have released a new version of DS-CLI. You can download it from this link.

From the Release Notes:

WP-CLI and WordPress version 4.6 now use a shared library that can conflict and create runtime problems if they are not in sync (WordPress 4.6 trailed WP-CLI version. Please delete the prior ds-cli plugin folder before installation.

On Macintosh
1. Download the ds-cli-mac.zip file and unzip it.
2. Rename the ds-cli-mac.sfx file to ds-cli-mac
3. Using Terminal.app, make ds-cli-mac into an executable and run it, i.e.:
cd downloads
chmod +x ds-cli-mac
./ds-cli-mac
4. After the archive unpacks, move the resulting ds-cli folder into your /Applications/XAMPP/ds-plugins folder (replacing prior ds-cli).

On Windows
1. Download the ds-cli-win.zip file and unzip it.
2. Rename the ds-cli-win.sfx file to ds-cli-win.exe
3. Execute the ds-cli-win.exe file (double click it)
4. After the archive unpacks, MOVE (Do not copy) the resulting ds-cli folder into your c:\xampplite\ds-plugins folder (replacing prior ds-cli).